Linux公社论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 115|回复: 0

[问题求助] Ubuntu apt安装的eclipse启动异常(java.lang.ClassNotFoundException: org.eclipse...

[复制链接]

380

主题

5

听众

1000

积分

超级版主

Rank: 8Rank: 8

Rh08 发表于 2018-12-20 22:05:31 |显示全部楼层
Ubuntu apt安装的eclipse启动异常(java.lang.ClassNotFoundException: org.eclipse.core.runtime.adapt)

启动异常之后eclipse会提示查看logs,查看后会看到这个异常提示:

java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter

关于这个问题我是参考了stack overflow 里面一个同样的问题,下面给出链接:

https://stackoverflow.com/questi ... aptor-eclipsestarte
这个错误提示的意思是eclipse运行所需要的某个类缺失了,需要在eclipse安安装目录下的plugins里面添加这个文件进去,stack overflow里面那个人给出的连接里面并没有那个文件,而且在百度里面也找不出来,

这里给上我的资源


解决完这个问题之后还会出现一个异常提示如下:
org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.simpleconfigurator_1.0.301.dist [1]" could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,J2SE-1.4

解释一下这个错误提示的意思是缺少捆绑需求的执行环境,eclipse本身是一个java程序,我们都知道java程序是要在java虚拟机上运行的,所以需要在eclipse的配置中制定你的jvm安装目录下的./bin/java文件来编译eclipse程序。通过终端打开eclipse安装目录下的eclipse.ini 文件,然后修改其中的配置



在文件中加上我在图片中选中的两行,记得java目录要改成自己对应的安装路径,希望能对大家有所帮助。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

您需要登录后才可以回帖 登录 | 注册

关注Linux公社官方微信,免费领取邀请码。

手机版|Linux公社(LinuxIDC.com)旗下网站【www.linuxidc.net】 ( 浙ICP备06018118号 )

GMT+8, 2019-3-27 00:29 , Processed in 0.046003 second(s), 8 queries , Wincache On.

Powered by Discuz! X 3.2

© 2010-2016 Comsenz Inc.

回顶部